508,402 active members
3,779 visitors online
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Benchtop Machines > My 500W 10.5A 48V PSU is here and installed.
Results 1 to 4 of 4
  1. #1
    Registered
    Join Date
    Feb 2007
    Posts
    632

    My 500W 10.5A 48V PSU is here and installed.

    Hi guys,

    To update on what I have done lately. Just received my PSU from ebay. I hooked it up in place of the 24V PSU and fired up Mach3 and the drivers. Wow! just wow! I can rapid at 200 IPM without binding issue.

    I am not going to cut at this speed of course but having the extra torgue and speed is well worth the money I spent.

    Just one thing though, not sure if it is faulty or what, but the built in fan isn't working. Not sure why.

    Can someone tell me what the terminals stands for. I have DC1 (V+), DC2, GRD1 (COM), GRD2, GRD3, FG, L and N. I know all except FG. Looks like it could be for the internal fan. Any idea what this terminal is?

    I am using Keling KL5056 drivers and Keling 495 oz.in motors.

    Alex

  2. #2
    Registered
    Join Date
    Feb 2007
    Posts
    632
    K, got a very prompt reply form the ebay seller. The fan will automatically turn on when the temp hits 50 degree mark. And FG stands for Frame ground.

    BTW, any advice when using this power unit? I am made to understand, motor will get hot when using a higher rated PSU, anything else to look out for?

    Alex

  3. #3
    Registered
    Join Date
    Jul 2006
    Posts
    887
    sparks? flames? magic smoke? those are what I would look for

    how much was the PSU and got a link for it? I will be in the market for a new one soon.

  4. #4
    Registered
    Join Date
    Feb 2007
    Posts
    632
    HI Fixitt,

    Hopefully that doesn't happen. I am coward when it comes to electricity. Scared of the stuff. Good thing I have a meter handy for measuring the output. But I did managed to fry my other fan though. It was working fine under 24V, obviously can't take 48V.

    Anyway, This is where I got the PSU.

    Fast shipping. Highly recommended. Some though aren't too comfortable getting from Hong Kong. Me too but this one's legit.

    Alex

Similar Threads

  1. Installed tach on 8x14
    By arekugi in forum Mini Lathe
    Replies: 1
    Last Post: 02-18-2008, 07:19 AM
  2. Macro B installed?
    By grweldon in forum Fanuc
    Replies: 8
    Last Post: 07-09-2007, 07:19 PM
  3. Omron 500W AC Servo driver for robot setup
    By robo_plasma in forum Servo Motors / Drives
    Replies: 0
    Last Post: 01-06-2007, 10:28 PM
  4. Help gettig pure dos installed
    By Hack in forum TurboCNC
    Replies: 11
    Last Post: 10-03-2005, 03:26 AM
  5. Caps Installed Wrong Please HELP
    By jockey in forum General CNC Machine Related Electronics
    Replies: 6
    Last Post: 02-27-2005, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •