547,565 active members*
2,824 visitors online*
Register for free
Login
Results 1 to 3 of 3
  1. #1
    Registered
    Join Date
    Mar 2015
    Posts
    7

    Spindle RPM not correct

    Hi Guys
    Finally got around to setting up the Spindle control with UCCNC - AXBB-E and my HY VFD.
    Everything is working great apart from the RPM is not accurate.
    When Sset calls for 12000 RPM the VFD is correct and shows 12000 RPM
    When Sset calls for 16000 RPM the VFD only reach's about 14800 RPM just about 10% difference
    When Sset calls for 1800 rpm the VFD only reads 16500 RPM
    When Sset calls for 24000 RPM VFD only shows 20000 RPM

    The error gets bigger the higher the RPM
    What settings do I need to adjust to get the VFD to reach the correct RPM?



    Cheers

  2. #2
    Member
    Join Date
    Jan 2005
    Posts
    12828

    Re: Spindle RPM not correct

    Quote Originally Posted by Borneoben View Post
    [FONT="]Hi Guys
    Finally got around to setting up the Spindle control with UCCNC - AXBB-E and my HY VFD.
    Everything is working great apart from the RPM is not accurate.
    When Sset calls for 12000 RPM the VFD is correct and shows 12000 RPM
    When Sset calls for 16000 RPM the VFD only reach's about 14800 RPM just about 10% difference
    When Sset calls for 1800 rpm the VFD only reads 16500 RPM
    When Sset calls for 24000 RPM VFD only shows 20000 RPM

    The error gets bigger the higher the RPM
    What settings do I need to adjust to get the VFD to reach the correct RPM?


    [/FONT]

    Cheers
    Have you checked the voltage output at those speeds @ 12000 it should be around 5v

    Have you set the Spindle Velocity Minimum and Maximin 6000 and 24000 for water cooled spindle in the UCCNC software
    Mactec54

  3. #3
    Registered
    Join Date
    Apr 2013
    Posts
    1880

    Re: Spindle RPM not correct

    Quote Originally Posted by Borneoben View Post
    Hi Guys
    Finally got around to setting up the Spindle control with UCCNC - AXBB-E and my HY VFD.
    Everything is working great apart from the RPM is not accurate.
    When Sset calls for 12000 RPM the VFD is correct and shows 12000 RPM
    When Sset calls for 16000 RPM the VFD only reach's about 14800 RPM just about 10% difference
    When Sset calls for 1800 rpm the VFD only reads 16500 RPM
    When Sset calls for 24000 RPM VFD only shows 20000 RPM
    The error gets bigger the higher the RPM
    What settings do I need to adjust to get the VFD to reach the correct RPM?

    Cheers
    Where does the RPM reading comes from? Is it from an external meter, or from the VFD? It sounds like you have a very bad and poor quality D/A converter. Perhaps the AXBBE is faulty, or it is incorrectly configured. Measure the RPM, and the D/A output voltage to check which is right and which is wrong. Perhaps the VFD is the problem. Difficult to say with so little facts about what is measured where.

Similar Threads

  1. Haas Vf2 8100-rpm or 10,000-rpm Spindle
    By SuperTico in forum Haas Mills
    Replies: 4
    Last Post: 01-13-2019, 06:25 PM
  2. Need correct RPM and feed rate for 1" spade drill, drilling titanium
    By leoliver in forum Uncategorised MetalWorking Machines
    Replies: 1
    Last Post: 12-12-2016, 10:08 AM
  3. spindle not correct rpm and surging
    By billsnogo in forum Fadal
    Replies: 6
    Last Post: 07-15-2015, 03:57 AM
  4. Replies: 4
    Last Post: 10-03-2013, 07:19 PM
  5. High speed spindle & correct RPM ?
    By Babba in forum Syil Products
    Replies: 6
    Last Post: 04-24-2008, 10:46 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •