529,917 active members*
2,286 visitors online*
Register for free
Login

Thread: turret issue

Page 1 of 2 12
Results 1 to 20 of 25
  1. #1
    Registered
    Join Date
    Aug 2005
    Posts
    36

    turret issue

    2004 puma 240L fanuc 21i-TB we had the servo battery go bad 3.6 volt. we replaced that yeserday ran the machine turned on and ran today for an hour then we got alarm 2023 (not locking in the 10 sec interval) then switches to alam 2047 (turret clamp switch alam or turret control unit alarm

  2. #2
    Registered
    Join Date
    Oct 2007
    Posts
    9
    Check your PLC output relay for the clamp/unclamp cct. Chances are both solenoids are in the ON state for the hydraulic turret clamp. This means one of your output relays is fused shut.

  3. #3
    When you changed the servo battery. did you reset parameter 8 on the promotion unit ?
    This sets the 'current' clamped position tool number

    If you hit the e-stop can you turn the turret by hand ?

  4. #4
    Registered
    Join Date
    Mar 2007
    Posts
    75

    Question Daewoo 2023 error

    I got one that has an intermittant turret issue. Works great going CCW but has 2030 error when going CW. I removed and cleaned the Yuken valves. This helped some but still have the error periodically. Swapped battery in servo. Not sure how to reset parameter #8 on promo unit. Any help? Could this be my problem?

    Thanks in advance.

    Hotrob1

  5. #5
    Try M-Man's procedure on this thread

    http://www.cnczone.com/forums/showthread.php?t=43020

    this is the procedure to reset the position the turret stops at to clamp

  6. #6
    Registered
    Join Date
    Mar 2007
    Posts
    75

    Question Still got it.

    I appreciate the response. Still getting 2030 error. (each tool indexing is not finished within 20 sec after tool index command) Thinking it may be the clamp/unclamp confirmation switch. Any thoughts? Thanks.

    Re: 2030 error (Daewoo 200)

  7. #7
    2030 M17 OR M18 IS COMMANDED IN ILLEGAL MODE, PLEASE CONFIRM MDI MODE.

    Please recheck this is the error you are getting



    as for checking the turret clamp unclamp

    you can either take the guard off and see if the proximity switch at the back is lighting up

    or you can change K5.4 and check X7.0 to also see if the clamp confirmation switch is operational.

    The fact that it is working in one direction indicates that it is not orientating the turret correctly before it clamps. Which indicates to me that the promotion servo controller is not orientating the turret to the correct position
    or overshooting

  8. #8
    Registered
    Join Date
    Mar 2007
    Posts
    75

    Update

    I turned down the pressure and right now the turret is working w/o errors. It is working slow of course but able to produce parts. I'm going to leave it as is for right now but I do appreciate the responses and may hollar back once it becomes an issue again. Not sure what the pressure had to do with it unless it was running a little high. Again, thanks.

  9. #9
    Registered
    Join Date
    May 2007
    Posts
    16
    i had similar issue, was actualy the limit prox sensor, had to adjust it.

  10. #10
    Registered
    Join Date
    Oct 2014
    Posts
    1

    Re: turret issue

    Hello MysticMonkey I did change the servo battery and now my tuuret is in the wrong position (bout and 1.0" off) and I can turn it by hand when off. we r not sure what to do any suggestions would b great thank you

  11. #11
    Member
    Join Date
    Feb 2013
    Posts
    693

    Re: turret issue

    Quote Originally Posted by Raina View Post
    Hello MysticMonkey I did change the servo battery and now my tuuret is in the wrong position (bout and 1.0" off) and I can turn it by hand when off. we r not sure what to do any suggestions would b great thank you
    Mystic Monkey hasn't posted in two years.

    When you hydraulics are running, does the turret turn by hand?

    It is likely that the curvic is not properly engaged.
    Use k5.4 to open (set to 1) and close (set back to 0) until the curvic moves itself (rotationally pulled into grove) when clamping.
    Then use the instructions in the Blue Book to do an ORiGin Set (it looks like OR9.5)
    (set parameter 8 to the same as the current position of the turret...select ORG.S...press and hold SET until display "rolls"...power off)
    at power on, it should be correct.
    Doosan Service Technician
    darryl.hardt@doosanmt.com O:973-618-2461 M:973-803-9479

  12. #12
    Registered
    Join Date
    Oct 2012
    Posts
    8

    Re: turret issue

    I'm having a similar issue with a Doosan Puma 240. We get a 2023 alarm followed by a 2047 alarm. Only thing is it is intermittent. In the machine's service notes it says we have replaced the KA31 relay a few times and more recently we replaced both coils on the hydraulic solenoid. Any ideas? Tomorrow we will replace the KA31 relay.

  13. #13
    Member
    Join Date
    Feb 2013
    Posts
    693

    Re: turret issue

    Take a look at the Troubleshooting section for each alarm, attached.

    Check out the action on the proximity switch for the DOG.

    Is the DOG rod "sluggish"? (it might need disassembly and cleaning or replace)
    Is the proximity switch dirty or out of alignment?

    Read the attached sections and check any other items mentioned, also.
    Doosan Service Technician
    darryl.hardt@doosanmt.com O:973-618-2461 M:973-803-9479

  14. #14
    Registered
    Join Date
    Oct 2013
    Posts
    15

    Re: turret issue

    Hey Darryl,

    I am getting the 2047 error on my Daewoo MX2000ST. If I toggle keep relay 5.4 I can get it to clamp (0) and unclamp (1) to where it spins freely by hand. However, the alarm won't go away and I can't get it to rotate using the turret switch on the control. Where would I find the DOG and turret sensor on my machine? Thanks.

    Roy

  15. #15
    Member
    Join Date
    Feb 2013
    Posts
    693

    Re: turret issue

    If curvic is engaging incorrectly the alarm will continue.

    If curvic engages correctly, you should feel it jerk in rotation.

    If correct engagement, the dog is on the opposite side from the toolpost, it has a proximity switch.
    Doosan Service Technician
    darryl.hardt@doosanmt.com O:973-618-2461 M:973-803-9479

  16. #16
    Registered
    Join Date
    Oct 2013
    Posts
    15

    Re: Daewoo 2023 error

    I pulled the back cover off and can see that the turret switch sensor and the DOG appear to be functioning correctly. The sensor lights up when the turret is clamped (5.4=0) and the DOG moves forward and the light goes off when the turret is unclamped (5.4=1). I can turn the turret freely when it is unclamped and I can feel it clamp into place when it is clamped. The 2047 alarm still will not go away. Any suggestions?

  17. #17
    Registered
    Join Date
    Oct 2013
    Posts
    15

    Re: turret issue

    It turned out that the battery was dead on the Pro-Motion Servo for the turret. Replaced the battery and reset the parameters and we're good to go!

  18. #18
    Member
    Join Date
    Feb 2013
    Posts
    693

    Re: Still got it.

    There should have been a different alarm that stated the battery was getting low, and another alarm that claimed an error with the servo turret from a dead battery.
    Did either of those alarms ever occur?
    Doosan Service Technician
    darryl.hardt@doosanmt.com O:973-618-2461 M:973-803-9479

  19. #19
    This happens frequently when the battery on the AC promotion or Vision drives die and the machine is powered down for more then 30 minutes. You have input the parameters again for the correct tool post amount (8,10 or 12). Then change keeper 5.4 and align turret in X axis and everything should be good again.

  20. #20
    Registered
    Join Date
    Apr 2015
    Posts
    2

    Re: turret issue

    Markjb I have the same lathe and still have the issue, I cant seem to reset the alarm, any suggestions? or can you help me get a step by step guide. Thank you

Page 1 of 2 12

Similar Threads

  1. QT28 turret issue
    By Paul in OK in forum Mazak, Mitsubishi, Mazatrol
    Replies: 2
    Last Post: 11-05-2012, 10:37 PM
  2. Daewoo Puma 230 Turret issue
    By atscnc in forum Daewoo/Doosan
    Replies: 4
    Last Post: 10-15-2011, 01:13 PM
  3. Servo Turret Issue
    By Tom Slick in forum Fadal
    Replies: 13
    Last Post: 03-03-2008, 05:34 PM
  4. Leadwell GTC-20 turret issue
    By hutch07 in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 0
    Last Post: 12-14-2007, 03:23 PM
  5. another turret issue
    By Paul in OK in forum Daewoo/Doosan
    Replies: 0
    Last Post: 05-24-2007, 05:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •