540,709 active members*
6,953 visitors online*
Register for free
IndustryArena Forum > MetalWorking Machines > Hardinge Lathes > Very strange problem with spindle
Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2012

    Unhappy Very strange problem with spindle

    Update: I can start the spindle directly from the drive. It appears that the control is not sending the run signal to the drive. My troubleshooting tree says to check for open circuit between s1 and sc or between s2 and sc to determine is it is not getting a run signal or if it get both run and stop signals but I do not know how to check for an open circuit while the power is on so I unhooked the s2 stop signal wire and had the same result. This seems to indicate no run signal.

    I have a Hardinge Cobra 42 lathe with fanuc 21i-t control. It was sold to us with a turret problem that I have since fixed but the spindle does not work. The machine had all of its parameters wiped and input by hand but I have triple checked everything and nothing seems wrong with them now although I cant check the K Words. I also have an older working Cobra 42 (21i) that I can check against to get an idea of how everything is supposed to work.

    Now for the problem:
    When I turn on the spindle in MDI mode with any of the commands (m3/m13/m4/m14)(g97/g96) I hit cycle start and the cycle start button illuminates but the spindle does not start. The spindle rotates freely by hand (activated or not) and the spindle speed readout works when rotated by hand. There are no error codes at all and I have left it with the cycle start on for hours at a time with not change. The MagneTek 506 drive reads an input frequency but no output frequency, power, etc. There are three power output wires from the MagneTek to the motor and each of these read about 10V. In the PMC ladder I checked all of the "spindle starts here" logic against my working machine and it all seems to be in order. There are two rungs I have found that do not work properly and these are "M3 or M13" and "M3 Delay" these two rungs are supposed to be energized for a moment and then the spindle starts but on this machine they stay energized and the spindle does not start so this seems to be where the hang up is.

    Other information that may or may not be related:

    Coolant pump was not wired up until yesterday and without a diagram from when it was unhooked it may not be wired properly but I cant check it without activating the spindle.

    Spindle bearings were replaced but the previous owner said the spindle worked before and after this operation.

    Drive batteries died (thus the parameter wipe) and were very low when we got it but new batteries now.

    Every other function works properly.

    There is a toggle switch that is wired to the IO board to supply 12 volts but the output end is not attached to anything and the switch is in off position.

    The spindle motor makes no noise to indicate it is running.

    The spindle is attached to the motor via belt which seems to be at proper tension and rotates when the spindle is rotated by hand.

    Any insight would be greatly appreciated,
    Thank You

  2. #2
    Join Date
    Jul 2012
    Definitely narrowed it down to the control not issuing the run command (enable spindle) the wire comes directly from the control to the drive and the other wire pair that runs from the same plug work fine (it provides the reference frequency for the drive)

    Had a tech from Hardinge (Gossager) come out and he was equally baffled, said he would have to see if anyone else had seen this kind of problem but I haven't heard anything back yet.

  3. #3
    Join Date
    Jul 2012
    Today I found that the control thinks it is sending the signal
    I checked continuity in all the related wires
    Finally I noticed there is no output from the three phase controller (EUAC220) that is wired into the spindle drive. This is a safety device that intercepts the run signal from the control to prevent damage to the drive. Oddly enough there is not much info about it online, I barely found out that the missing light means no output.

    Anyone have any experience with these components?

  4. #4
    Join Date
    Jul 2012
    SOLVED: It was out of phase, knew it had to be something simple, switched the two 120V wires and it works just fine now

  5. #5
    Join Date
    Mar 2019
    Do you still have this machine available?

  6. #6
    Join Date
    Apr 2012

    Re: Very strange problem with spindle

    Hey Scott,

    Thanks for posting all this. It helped me fix that problem too.

Similar Threads

  1. Help with strange problem
    By JLOASE in forum LinuxCNC (formerly EMC2)
    Replies: 9
    Last Post: 10-11-2012, 01:46 AM
  2. Strange X4+ problem
    By Mud in forum Syil Products
    Replies: 15
    Last Post: 09-24-2009, 03:08 AM
  3. Strange Problem
    By mrcosmos in forum Mach Software (ArtSoft software)
    Replies: 4
    Last Post: 08-17-2008, 01:55 PM
  4. CNC strange problem
    By huben_123 in forum TurboCNC
    Replies: 4
    Last Post: 03-15-2008, 12:12 AM
  5. Strange G03 problem
    By sploo in forum Mach Mill
    Replies: 4
    Last Post: 11-15-2006, 12:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts