501,579 active members
5,268 visitors online
Register for free
Login
Results 1 to 6 of 6
  1. #1
    Registered
    Join Date
    May 2015
    Posts
    3

    Laser tube problem or?

    Hi,

    Just got my first laser, a gweike 1390. I got the water running and tube connected but it wont fire (reci tube). I hear a small electric sound when I push laser, sounds like it comes from the plus-side of the tube. I have tried to move the magnet on the door switch but no difference. On the PSU the red diod lights up when i push laser and the fan is running. Don't see any colour of the tube either when pushing laser.
    Any ideas or suggestions?

    Best regards,
    Mike

  2. #2
    Registered
    Join Date
    Mar 2015
    Posts
    79

    Re: Laser tube problem or?

    It sounds like your tube may be arcing to the frame. Stop firing it until you get it fixed or you will ruin the power supply and possibly other components.
    You need to insulate the high voltage connection better with silicone or high voltage tape. Be careful because the tube is fragile at that connection.
    Gweike should help you out further. It's also possible that you could be arcing at the power supply end. Be careful, it's all very high voltage when firing.

    Gozzie

  3. #3
    Registered
    Join Date
    May 2015
    Posts
    3

    Re: Laser tube problem or?

    Quote Originally Posted by Gozzie View Post
    It sounds like your tube may be arcing to the frame. Stop firing it until you get it fixed or you will ruin the power supply and possibly other components.
    You need to insulate the high voltage connection better with silicone or high voltage tape. Be careful because the tube is fragile at that connection.
    Gweike should help you out further. It's also possible that you could be arcing at the power supply end. Be careful, it's all very high voltage when firing.

    Gozzie

    Thanks Gozzie for the quick reply. I wait for the response from Gweike before proceeding.
    /Mike

  4. #4

    Re: Laser tube problem or?

    Hello Mike
    Good day
    laser tube wont fire ,have as follow reason : ?
    1) First you can put a paper at the out laser port of laser tube , press" laser " at the laser screen , check if have laser out ? if no laser , maybe laser tube and laser supply power is bad either .
    the same time ,please also check amperemeter if have move when you press "laser" .
    2) if have laser out , please adjust laser mirror . it is ok .

    Kind regards
    Frank
    AccTeck CNC
    Jinan AccTek Machinery Co., Ltd

  5. #5
    Company Representative
    Join Date
    Feb 2012
    Posts
    387

    Re: Laser tube problem or?

    Dear Mike
    Here is the video for test no laser ,hope it can help
    GWEIKE LASER test for no laser - YouTube

    Quote Originally Posted by _MI_ View Post
    Hi,

    Just got my first laser, a gweike 1390. I got the water running and tube connected but it wont fire (reci tube). I hear a small electric sound when I push laser, sounds like it comes from the plus-side of the tube. I have tried to move the magnet on the door switch but no difference. On the PSU the red diod lights up when i push laser and the fan is running. Don't see any colour of the tube either when pushing laser.
    Any ideas or suggestions?

    Best regards,
    Mike
    Lucy Lee G.WEIKE LASER
    han@wklaser.com

  6. #6
    Registered
    Join Date
    May 2015
    Posts
    3

    Re: Laser tube problem or?

    [QUOTE=gweikelaser;1710402]Dear Mike
    Here is the video for test no laser ,hope it can help


    Thanks Lucy for the video. Have not seen any cracks and the amp meter doesnt move. Will look into the other points.
    A question concering earth or ground of the machine. Here it is very common that we have ground/earth in our wall sockets. If you connect the Laser to a gounded/earthed wall outlet/socket. Do you still need to separate wire to ground/earth? And in that case, can that separate wire be connected to the wall socket ground/earth?

    Best regards,
    Mike

Similar Threads

  1. laser tube problem
    By geekinesis in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 10
    Last Post: 06-21-2016, 09:12 PM
  2. Replies: 0
    Last Post: 06-11-2014, 10:10 AM
  3. small bubbles in laser tube, problem?
    By fdm_guy in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 3
    Last Post: 12-06-2013, 09:39 AM
  4. Reusable CO2 100W 130W 150W Laser Tube ? Replace the traditional CO2 laser tube
    By dianmanlaser in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 7
    Last Post: 04-03-2013, 05:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •