554,259 active members*
4,009 visitors online*
Register for free
IndustryArena Forum > CAM Software > TurboCAD/CAM > TurboCadCam V21 turbocad with 3.5 cam plugin simulator not running
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Sep 2013

    TurboCadCam V21 turbocad with 3.5 cam plugin simulator not running

    I have an older copy of TurboCad V21 that does everything in cad that I need. I also use CamBam for generating Gcode for my Linux based CNC machine. Wanted to have an all in one application that would simulate the code also so I bought the V21 plugin
    which is actually TCC V3.5. Installed fine and runs almost perfect. Info on using it is in the helps but that could be a lot better. I did find a few videos on the tube that helped a bit.

    Actually the simulator does run but the tool bar is not launched and it completes it's cycle in a few milliseconds never showing the cut path.

    The main problem is that the simulator tool bar does not get created when I hit the simulate button. The gcode runs and the screen display flashes but it does not show the simulation running line by line. Now when you pick a line of Gcode it does show up on the graphic and you can single step thru the code and see the result on the drawing. I think that My Win 10 software on my 3 year old Dell pc is just "too fast" for this bar to show up or some other Win10/TCC compatibility issue.

    Pulled out my really old Dell 8300 with winXP on it. Installed Tcad and Tcc and yep, you guessed it, every thing works as it should.
    What do I need to do to Win10 to get this to run on it? I have tried every compatibility setting in Win10 without luck.

    I may have to just bite the bullet and use the WinXP machine to simulate unless there is another solution.

    Thanks in advance, JR

  2. #2
    Junior Member
    Join Date
    Sep 2013

    Smile Solved the mystery

    After installing a new video card driver for my Win10 Dell desktop the problem still exists.
    Loaded the TurboCad and Cam on my 1 year old Lenovo notebook and it worked right off without any problems.
    I had found some new versions of the program and the cam plugin on the internet and loaded them, not the ones that I had bought on the DVDs.

    Deleted the Tcad and Tcc from my Dell desktop where the simulator would not work.
    Deleted the file folders that the app removal program left in the Xx86 directory.
    These are the files that I used for the new install:
    TurboCAD_Pro_21-2_71-0_x86.exe for the 32 bit version of Tcad.
    CAM_PlugIn_for_TurboCAD_v21.exe 24,809 KB for the Cam plugin.

    Now I have it working on my old XP desktop,Win10 Desktop and Win10 Lenovo note.

    These links provided the files that worked for me.
    Tcad V21 http://forums.turbocad.com/index.php?topic=14338.0
    Cam: http://forums.turbocad.com/index.php/topic,15550.0.html

    The above links were the latest files I could find and the ones that worked.

    Cheers, JR
    Last edited by jjr2001; 08-29-2017 at 02:17 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts