501,555 active members
4,794 visitors online
Register for free
Login
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    Mar 2011
    Posts
    313

    noisy motor help

    I have 4 of the 5 amp 570 in/oz nema 23 steppers. I finally got my machine up and running but I am having an issue with one of the motors.
    If I only have my Z, Y and A motors plugged in all is well but when I plug in my X motor ALL the motors start to make a kind of hissing,buzzing noise at idle.
    Unplug the X motor and all go quiet. Plug it back in and all get noisy.

    Here is a grid of what I have tried
    Motors plugged in
    A X Y Z noisy
    X Y Z noisy
    A Y Z quiet
    AX noisy
    AXY noisy
    XY noisy
    XYZ noisy
    YZ quiet

    So you can see the only time the motors get noisy is when the X motor is plugged in.

    I am using KL 5056 E drivers
    I am running Arduino/GRBL
    The X and A drivers are connected to the same port on the arduino.

    I think I have a bad motor.
    Please help.

  2. #2
    Registered
    Join Date
    Mar 2011
    Posts
    313

    Re: noisy motor help

    no replies from automation tech?

  3. #3
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Posts
    33739

    Re: noisy motor help

    The X and A drivers are connected to the same port on the arduino.
    This is possibly the issue. Swap the X motor and drive with one of the others, and see if the same thing happens when you add the 4th motor.
    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

  4. #4
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Posts
    33739

    Re: noisy motor help

    Quote Originally Posted by tkms002 View Post
    no replies from automation tech?
    If you want tech support, email them directly. That's always the best method, for any company.
    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

  5. #5
    Registered
    Join Date
    Mar 2011
    Posts
    313

    Re: noisy motor help

    Quote Originally Posted by ger21 View Post
    This is possibly the issue. Swap the X motor and drive with one of the others, and see if the same thing happens when you add the 4th motor.
    Ok. It does not matter what driver the X motor is plugged in to. It causes the noise when connected to any of them.

Similar Threads

  1. Motor/stepper issue : blocking, slowing down, being noisy
    By nicolasd5150 in forum Mach Software (ArtSoft software)
    Replies: 3
    Last Post: 04-27-2015, 04:37 PM
  2. Drove gantry into hard stop, now stepper motor is very noisy
    By N2950H in forum General CNC Plasma / Oxy Fuel Cutting Machines
    Replies: 10
    Last Post: 01-23-2015, 02:12 PM
  3. Noisy z axis
    By forseral in forum K2CNC
    Replies: 21
    Last Post: 04-12-2012, 01:47 AM
  4. Noisy rack
    By Robin Hewitt in forum General Waterjet
    Replies: 7
    Last Post: 10-10-2007, 07:00 PM
  5. Noisy J2 head
    By Healey in forum Bridgeport / Hardinge Mills
    Replies: 7
    Last Post: 02-05-2007, 11:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •