512,821 active members
2,929 visitors online
Register for free
Results 1 to 8 of 8
  1. #1
    Join Date
    Oct 2006

    Linuxcnc to Mach3


    just got my self a Boxford 125tcl. all up and running with Linux cnc. problem is that I don't know Linux, so as my other cnc stuff is Mach i though i would convert it over.

    I got the pin's etc from Linux (.HAL file) and put them into mach . This has worked for the X,Z, Tool changer and for M3 spindle but M4 is not working.
    The info i got from Linuxcnc for the spindle is

    step=pin 14
    CW=pin 16
    CCW= pin 1

    put this into mach....

    spindle step=pin14
    CW output #1 / output#1=pin16 port 1
    CCW output#2 / output#2=pin1 port 1

    this, i have entered in to Mach, but it seems its not turning on pin 1 to trigger the relay on the BOB. I have changed CCW to pin 16. and when you enter M4 the spindle will start but goes CW.
    think i may of missed something with in the Linux settings.

    the boxford has all its original electronics, but has a C11 and a C6 board. i'm using a usb smooth stepper.

    unless i can get it going CCW its a bit of a paper weight at the mo.

    any help with this would be great.

  2. #2
    Join Date
    Aug 2006

    Re: Linuxcnc to Mach3

    have you used a meter to check pin1 status when it should be on?

  3. #3
    Join Date
    Oct 2006

    Re: Linuxcnc to Mach3

    no meter check, but if you lift the lid of the lathe (turns on safety switch) you can hear the c11 relays click and the spindle doesn't come on. the pin 16 relay clicks. pin1 relay doesn't.

    can do the meter check tomorrow just to be on the safe side.

  4. #4
    Join Date
    Oct 2006

    Re: Linuxcnc to Mach3

    tried some things today..

    just for ease I told mach3 the coolant (m8) is output 2 pin 1 the same as the CCW trigger. but before I did this I told it was output 1. so when you turn on the coolant you can hear the relay for pin16 come on. change it over to pin 1 and nothing happens.

    in mach3's diagnostics page, output 1 and 2 light up when called for. that would suggest mach is doing what's its told but the SS is not sending it to the C11.

    now thinking it may be something with the smooth stepper, I'm booting up the pc that the lathe came with, with W7 so I can use the parallel port on it. this will take out the SS. if it works it's the SS, if it doesn't...…… back to square one.

  5. #5
    Join Date
    Oct 2006

    Re: Linuxcnc to Mach3


    just got the other pc going, installed mach. took the machturn file of the other pc. typed M4 s1000 in the MDI line. and the chuck started going CCW.

    so all is well using the parallel port but not with the SS.

    any ideas?

  6. #6
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003

    Re: Linuxcnc to Mach3

    Maybe you are missing some settings in the plugin?

    UCCNC 2017 Screenset

    Mach3 2010 Screenset

    JointCAM - CNC Dovetails & Box Joints

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

  7. #7
    Join Date
    Oct 2008

    Re: Linuxcnc to Mach3

    I am am sure you have to setup the spindle in the Smoothstepper plugin configuration.

    However, you said you were just changing over from LinuxCNC to Mach 3. Last time I checked Smooth Stepper was not supported by LinuxCNC. Did you add the SS or is there now LinuxCNC support for the Smoothstepper?
    Bob La Londe

  8. #8
    Join Date
    Oct 2006

    Re: Linuxcnc to Mach3

    The lathe was running on Linux through the PP. I then got another pc (laptop) with mach3 on it and added the SS.
    Because of the problems, I then put a blank Hdd in the linux PC and put windows on it. Then run the lathe through the PP.

    With mach and the SS, cant get CCW from the spindle. with mach through the PP (no SS) i can get CCW to work. latter today i will put the SS on the PP PC to see if it's a laptop thing.

    as for the SS plug in. I can only see one bit that sets up the spindle and thats the PWM or step/dir options.

Similar Threads

  1. can i fix this directly from the cnc softwars (GRBL / LINUXCNC / MACH3 )?
    By abdelkrim30 in forum CNC Wood Router Project Log
    Replies: 1
    Last Post: 11-26-2018, 08:45 PM
  2. nm145 - mach3, or 4, or linuxcnc or PP?
    By t300 in forum Novakon
    Replies: 49
    Last Post: 01-11-2018, 02:38 AM
  3. Mach3 to Linuxcnc
    By bill.anderson in forum Shopmaster/Shoptask
    Replies: 18
    Last Post: 07-17-2016, 03:14 AM
  4. Mach3 vs LinuxCNC vs USBCNC vs CNCUSB
    By emptystr in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 2
    Last Post: 05-08-2015, 03:49 AM
  5. grbl vs mach3 vs linuxCNC
    By speed_racer in forum Benchtop Machines
    Replies: 0
    Last Post: 05-08-2015, 02:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts