505,893 active members
2,575 visitors online
Register for free
Login
Results 1 to 8 of 8
  1. #1

    Join Date
    Sep 2019
    Posts
    31

    Earthing problem

    Hi all
    I need a quick fix,
    Problem is, when Mach 3 plasma is booted up my keyboard arrow signals with move the axis on screen ok,
    When I switch on the power inverter to power the stepper drivers the signals is still ok on the screen,
    But when I switch power on to the stepper drivers the screen is non responsive and sometimes I get message from the computer saying the USB being used has lost its ,

    I have changed to new keypad and new computer that we had spare for back up.
    Could this be a earth problem somewhere

    Thanks Guys

  2. #2

    Re: Earthing problem

    It could be an earthing problem. From what you describe it sound like that the stepper drives are so electrically noisy that they are blanking the USB signal to the board. Maybe a well shielded USB cable would help.

    Did this system ever work correctly? If so, then what has changed?
    Jim Dawson
    Sandy, Oregon, USA

  3. #3

    Join Date
    Sep 2019
    Posts
    31
    Hi Jim,
    Yea this system has been running about 5 years now
    With no problems
    I know the guys cutting last week did hit the table
    A fair bang with the fork lift,
    But I did check around table for maybe nipped
    Cables but see no problems
    I'll try a better shielded cable tomorrow

    Thanks again Jim




    Quote Originally Posted by Jim Dawson View Post
    It could be an earthing problem. From what you describe it sound like that the stepper drives are so electrically noisy that they are blanking the USB signal to the board. Maybe a well shielded USB cable would help.

    Did this system ever work correctly? If so, then what has changed?

  4. #4

    Join Date
    Sep 2019
    Posts
    31
    Hi I have found a new problem with this
    On y axis and z axis, when I power up the drivers to
    Them two axis and put the tester on the shield around the
    Cable that goes from them to the motors I seem to get slot of DC voltage inaround 24v and this also disables the computer keyboard,
    So going to rewire them two motors in new and see
    If it's a broken or crossed wire somewhere
    Also if I connect these shields to the earth on the drivers
    It also freezes keyboard
    I have tried earthing table to ground peg earth and earthing table to control cabinet

    Tis dam confusing

  5. #5

    Re: Earthing problem

    Quote Originally Posted by Dem1 View Post
    Hi I have found a new problem with this
    On y axis and z axis, when I power up the drivers to
    Them two axis and put the tester on the shield around the
    Cable that goes from them to the motors I seem to get slot of DC voltage inaround 24v and this also disables the computer keyboard,
    So going to rewire them two motors in new and see
    If it's a broken or crossed wire somewhere
    Also if I connect these shields to the earth on the drivers
    It also freezes keyboard
    I have tried earthing table to ground peg earth and earthing table to control cabinet

    Tis dam confusing
    Well that makes no sense. I would think that earthing the table would be the proper thing to do. I think you have a short to a shield somewhere.
    Jim Dawson
    Sandy, Oregon, USA

  6. #6
    Community Moderator Al_The_Man's Avatar
    Join Date
    Dec 2003
    Posts
    23173

    Re: Earthing problem

    Quote Originally Posted by Dem1 View Post
    When I switch on the power inverter to power the stepper drivers the signals is still ok on the screen,
    But when I switch power on to the stepper drivers the screen is non responsive.
    Could this be a earth problem somewhere

    Thanks Guys
    Have you set up an earth star point ground where the service GND terminates also?
    The USB power is already grounded through the PC supply, if this is a tower PC etc.
    The stepper P.S. common may also require connecting to this star point.
    I usually make a habit of ground all supply common's if possible, whether instructions say or not.
    Max.
    CNC, Mechatronics Integration and Custom Machine Design

    “Logic will get you from A to B. Imagination will take you everywhere.”
    Albert E.

  7. #7

    Join Date
    Sep 2019
    Posts
    31
    Well I have it sorted now ,
    I bought new breakout board HG08
    And 2 drivers. CDW 872
    Along with new cabling on table and cabinet
    It worked out cheaper fix for me rather than spending man hours troubleshooting and down time cutting.

    Thanks all again for help
    Great forum here
    h
    Quote Originally Posted by Jim Dawson View Post
    Well that makes no sense. I would think that earthing the table would be the proper thing to do. I think you have a short to a shield somewhere.

  8. #8

    Re: Earthing problem

    Happy to hear it's working again :cheers:
    Jim Dawson
    Sandy, Oregon, USA

Similar Threads

  1. Maybe earthing problem
    By Dem1 in forum Stepper Motors / Drives
    Replies: 1
    Last Post: 09-17-2019, 12:33 AM
  2. Insulating transformer earthing/Driver Earthing
    By Cware in forum General CNC Machine Related Electronics
    Replies: 3
    Last Post: 09-27-2014, 10:47 PM
  3. Earthing rod installation
    By Simonh1959 in forum Hypertherm Plasma
    Replies: 6
    Last Post: 02-11-2013, 04:18 PM
  4. Why earthing laserengraver ?
    By froggygeorge in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 5
    Last Post: 02-15-2011, 11:50 AM
  5. earthing problem - help
    By neurofen in forum General CNC Machine Related Electronics
    Replies: 27
    Last Post: 01-22-2011, 04:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •