Hello. New to this forum.

We recently had a lightning strike at our shop that took out 1 of my Haas CNC mills as well as my PC. Believe it or not, the surge came through our RS232 cables...not the electric! We also have 2 lathes with their communication boards fried out. Anyway, I had to purchase a new PC. The lightning fried my previous USB to SERIAL adapter, so I bought a new one. It's supposed to be one of the best. It has the FTDI chipset in it. The driver is installed, all the port settings are set correctly to match the machine. The machine sends programs to my PC perfectly, but I can not get the machines to receive data from the PC. I've literally tried everything. I tried on multiple machines, including the ones that were uneffected by the lightning. So I don't think it's the RS-232 ports on the machines. I tried new cables and replaced all the hardware that was possibly affected. The LED light comes on the adapter when I try to send. My software indicates that the transmission was successful. Yet my machines just sit there waiting to receive. I've done many hours of research, tried every DNC setting, checked all of the hardware...nothing is working. Im running windows 10 just like my previous PC. I've tried through both CimcoEdit and Predator software. The old adapter was made by Tripp-Light. Never had any issues with it. The only thing I can come up with is that the new adapter is defective. I ordered a new one...different brand, different chipset. I will just have to see if it works. But PLEASE offer any suggestions if you have them! Thanks!