567,221 active members*
4,477 visitors online*
Register for free
IndustryArena Forum > CNC Electronics > DeskCNC Controller Board > imservice cnc router / DeskCNC controller and SV500 servo drives will not jog
Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2017

    imservice cnc router / DeskCNC controller and SV500 servo drives will not jog

    i bought a used IMservice cnc router that uses deskcnc controller and sv500 servo drives with servo motors

    its 3 axis

    im having some horrific headaches with thios thing..it is old but the prev owner used it 1 time and stored it ever since

    its in great condition but i cant get any of the axis to jog at all

    when i open deskcnc it opens to machine mode with DRO..the controller is flashing blue which is good...all 3 servo driver boards are solid blue which is good

    when i try to jog the DRO only moves .0001 at a time and the axis do not move...no matter if i have it in step mode or continuous mode the DRO only moves .0001

    i have tried just hooking up 1 axis enoder cable at a time and that has no affect

    ...alll the connections have been cleaned with contact cleaner and all connections look good...i have gone over this about 10 times...

    after 10hrs of working on it for some reason the axis started jogging fine and i then ran some test toolpaths and all was well..so i thought

    4 days later..i went to try again to use the machine and again the axis will not jog ....

    does anyone know anyhting about deskcnc controller?...there is very little info online and imservice went out of business and deskcnc tech support really is of no help.

    i have a hard time believing all 3 servo drives failed at once or all 3 servo motors failed at once and all 3 enocders failed at once

    something odd is going on that i cant not figure out

    like something is casuing interference...today even though axis would not jog a couple times the axis would just randomly move for no reason...very bizarre.

    although i get no movement during jog... if i try to home each axis each axis will just move a very short distance 2 times (.100 or so ) and just stop...x yand z all do this.

    so if home x it will move short distance..stop..then move short distance again and then stop...same with y and z but then other times if i try to home each axis i will just see the DRO move a small amount twice and the axis will not move...

    i also have the latest deskcnc software and latest firmware installed...and i have deskcnc controller generation2.

    i really hope someone can make light of whats going on....its just very bizarre.

  2. #2
    Join Date
    Dec 2020

    Re: imservice cnc router / DeskCNC controller and SV500 servo drives will not jog

    Hi, I have the same problem
    They gave me that cnc router but I can't get any movement of the axes. Download deskcnc trial mode to test it and if it worked buy it but it doesn't seem to make any move. I was looking for information to make it work with mach3 modbus but I think I'm not smart enough for this operation

Similar Threads

  1. Imservice cnc router with deskcnc controller?
    By Shelby5041 in forum Commercial CNC Wood Routers
    Replies: 2
    Last Post: 03-12-2022, 12:14 PM
  2. IMService Servo CNC Router review
    By buscht in forum Commercial CNC Wood Routers
    Replies: 14
    Last Post: 02-15-2022, 02:43 AM
  3. Hi Speed option for IMService CNC servo router
    By imserv in forum News Announcements
    Replies: 0
    Last Post: 07-12-2006, 10:16 PM
  4. SV500 servo drives
    By eman5oh in forum Servo Motors / Drives
    Replies: 5
    Last Post: 02-14-2005, 10:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts