532,233 active members*
3,863 visitors online*
Register for free
Login
Results 1 to 5 of 5
  1. #1

    Join Date
    Nov 2020
    Posts
    4

    Epilog Legend 32 Not working Missing capacitors

    Hello CNC Zone,

    I am a member of a hackerspace in the UK and we have received a Epilog legend 32 75w 6000 series laser cutter as a donation. Unfortunately, the machine doesn't work and one of our members has trace it back to 2 capacitors (c1007 & c1012) that appear to have broken off see attached images and have been lost

    We have contacted the local distributor who quoted us ~£1000 for a replacement board and we would have to install it ourselves.

    I wish to try and repair the board before shelling out that much but need to identify what the components were. I suspect they are the same as their neighbouring components but need to confirm.

    Is there anyone out there who has a legend 32 75w 6000 that would be willing to send me high res photos of the equivalent locations so i can compare the marking to confirm my theory or identify what they should be.

    The board may be common with other Epilog laser cutters but i don't know. The board part number is c1062934.

    Any help is much appreciated.

    thanks

    Jason

  2. #2
    Registered
    Join Date
    Nov 2012
    Posts
    989

    Re: Epilog Legend 32 Not working Missing capacitors

    Were those capacitors really broken off, or were they deliberately removed for frequency tuning at the factory? You might be barking up the wrong tree here.

  3. #3

    Join Date
    Nov 2020
    Posts
    4

    Re: Epilog Legend 32 Not working Missing capacitors

    CitizenOfDream,

    Thanks for the reply, that is definitely a possibility. I am not the first person to investigate this issue and can't get a hold of the original owner of the equipment to determine the condition when it was donated. The way it was describe to me was that the components had overheated and fallen off but i am not convinced from the images due to lack of burn/heating marks.

    I also think it is odd that the same component location (top in pictures) has been removed/is missing when both locations/components would have been exposed to similar temps. This supports your idea and the tuner would logically pick the same part to remove each time.

    If i could find pictures of other equipment that show the components and the owner say it is working then i would be able to use this to notify the space that spending 1k on a new board is more than likely a waste of time.

    From a google search for the board part number i have found the attached picture which appears to show 2 caps at each location but it is not clear and could be attached to a completely different spec of laser.

    Any helps is much appreciated.

    thanks
    Jason

  4. #4
    Registered
    Join Date
    Jul 2016
    Posts
    3

    Re: Epilog Legend 32 Not working Missing capacitors

    Looks like there are other problems with that board. Maybe it is just the picture but it looks like a cracked solder joint from repeated heating/cooling cycles. Check to see if the 2 caps were in parallel, looks like it or were separate. If one got so hot it fell off , chances are the other is toast.

    Solder needs to be removed and resoldered.

  5. #5

    Join Date
    Nov 2020
    Posts
    4

    Re: Epilog Legend 32 Not working Missing capacitors

    65patch,
    Thanks for the suggestion i believe they are in parallel but will check next time i am at the space, which could be some time as we are now in a covid lockdown and we have restricted access.

    I did think that the other caps might have bought it but haven't checked yet.

    Will let you know what i find.

    Jason

Similar Threads

  1. epilog legend 32
    By jgstang in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 23
    Last Post: 03-15-2018, 08:00 PM
  2. Replacing the x-axis motor on an epilog legend 24
    By edowney in forum Laser Hardware
    Replies: 0
    Last Post: 09-22-2017, 12:54 PM
  3. Want to buy: Epilog legend 36ext MOTHERBOARD
    By sanyyos in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 0
    Last Post: 01-10-2016, 11:58 PM
  4. Check out my new (to me) epilog legend 32!
    By Pplug in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 4
    Last Post: 12-22-2014, 08:45 PM
  5. Epilog legend 32 LCD won't display anything
    By OneAndy in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 6
    Last Post: 12-22-2014, 08:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •