525,431 active members*
2,271 visitors online*
Register for free
Login
IndustryArena Forum > CNC Electronics > Gecko Drives > G540 and Mach3 Random EStops Fixed For Me
Results 1 to 2 of 2
  1. #1
    Registered
    Join Date
    Jul 2015
    Posts
    0

    G540 and Mach3 Random EStops Fixed For Me

    I tried posting the following to a five year old thread on the same subject but it didn't show up. Just putting this out there for other people searching the same problem:


    Quote Originally Posted by CNCMAN172 View Post
    EvilSpeeder,
    As Mactec54 requested a few pictures might help. Here is what I think might be going on with your system. I am assuming you are using MACH3 with a parallel port setup, sounds like you are new so my guess is you used the default setup. You need to look under Configuration at the top of the page and then Ports/Pins and then look under inputs. The E-STOP function is my default assigned to a input pin, normally pin 15 if I remember correctly. Since you are just using an E-stop button or switch that disables the G540 stepper driver MACH3 knows absolutely nothing about that switch. You need to disable the E-stop function on the inputs page. It is probably looking at your parallel card and seeing the inputs floating, since they are not wired to anything in your situation for the E-stop pin. Check that out and you will probably resolve your problem. I would highly recommend you implement limits switches / home switches as well. Depending on your machine a few mistakes can be costly if you command the hardware to do something wrong by accident and you have no protection.
    Russ
    I know I'm committing necromancy here but this post just solved a problem that's plagued my mill for 3 damn years. Whenever the homing switches were plugged into my G540 I couldn't jog in X without tripping an "External estop requested" message. All of the replies about people plagued with this problem say the same thing: you definitely need shielded cables and proper grounds, so I spent dozens of hours and hundreds of dollars rewiring everything to no avail. The problem: when I setup mach3, I conflated my physical g540 estop switch with mach3's estop input. Previously the only way to run my mill was to physically disconnect the homing switch cable, but by disabling estop as an input (actually: setting it to an incorrect pin because mach3 won't let me disable it) the problem was instantly eliminated. Homing works perfectly and zero erroneous estops.

    So to anyone else, I say: before you buy new parallel extension cables, new stepper extension cables, crimping tools and hardware, terminal blocks, double shielded switch cables, a new meanwell power supply, and g16 plugs for everything, or call gecko support, just try disabling mach3's estop by setting it to pin 16 since it won't freakin' save the disabled "X".

  2. #2
    Registered
    Join Date
    Dec 2005
    Posts
    380

    Re: G540 and Mach3 Random EStops Fixed For Me

    Smap: Thanks, I have just by coincidence and by accident, just did what you suggested.
    I was debugging something else, took a guess and set the pins to 0( i think that is what i did).

    I also mistakenly removed my E-stop wiring from the gecko G540, but I guess I can now rewire it!

Similar Threads

  1. Gecko G540 Mach3 - Random Faults
    By 154james in forum Gecko Drives
    Replies: 0
    Last Post: 08-01-2015, 12:44 AM
  2. Random G540 problem
    By Odie9 in forum Gecko Drives
    Replies: 4
    Last Post: 03-05-2012, 11:49 PM
  3. G540 random fault
    By cd_edwards in forum Gecko Drives
    Replies: 0
    Last Post: 01-02-2012, 10:34 PM
  4. Random g540 Faults
    By bjmrtn in forum Gecko Drives
    Replies: 4
    Last Post: 12-18-2011, 03:16 PM
  5. random stalling g540
    By ihavenofish in forum Gecko Drives
    Replies: 8
    Last Post: 05-04-2009, 06:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •