529,951 active members*
2,146 visitors online*
Register for free
Results 1 to 1 of 1
  1. #1
    Join Date
    Jun 2010

    Mach3 homing slave axis not squaring up

    Good day gentle people.

    I am building a new plasma cnc table to replace my old table.

    A quick overview of the build
    NVEM network controller
    Closed loop stepper motors Hbs86h driver
    Limit switch for all axis

    A Axis is slaved to Y axis

    Machine moves well and is calibrated.

    Here is my problem
    With homing with master limit turned OFF in general config.
    When I reference all home
    The y axis moves to limit switch stops and A Axis does not square up. The system appears to hang. If I activate the A Axis limit manually. It goes green in diagnostic page.
    It appears that once the y axis has hit the limit switch. It is waiting for
    The A limit switch
    But A Axis does not move.
    X Axis does not home.

    If I turn on home with master in general config.
    The homing works fine for all axis.
    But no squaring up.

    I have set the soft limits page.
    On the soft limits page. A and Y axis are set the same.

    I would expect that of this was wrong. They would drive in opposite direction when homed.

    I have looked on many forums and tried multiple settings.
    But can't seem to get this working

    Any suggestions appreciated.


  2. #2
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003

    Re: Mach3 homing slave axis not squaring up

    You can try modifying the homing macro to use RefCombination to home the slaved axis.

    If that doesn't work, then there's a good chance you motion controller does not support slaved homing.

    UCCNC 2017 Screenset

    Mach3 2010 Screenset

    JointCAM - CNC Dovetails & Box Joints

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts