535,633 active members*
4,068 visitors online*
Register for free
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2017

    new K40 chinese laser only fires if I press "test" button

    . i have a brand new chinese k40 laser.. blue and white version.. no water sensor or door switch.. i was able to use the 'test' button on the panel and inside on the power supply and the laser will fire.. i did the alignment using the 'test' button on the panel.. then i installed all the corel and corel laser draw software and the USB key on my laptop.. i made a quick box and tried to send it to the laser cutter.. the laser cutter head moves as if it is working but the laser does not fire. I can hold down 'test' button during this and it will fire.. any suggestion?

  2. #2
    Join Date
    Sep 2016

    Re: new K40 chinese laser only fires if I press "test" button

    If you have a multimeter, check the voltages first. Please be extremely careful with the probes as they are generally fat and you can easily bridge something if you're not careful. I believe you should find both 5 and 24 volts on your controller board. The connector opposite of the USB should be the one that tells the power supply what to do. With the machine off, and unplugged, check continuity on both ends of this cable. It's labeled GND-YL-XL-GND-NC on the board -- it may be four or five wires, I don't recall what the harness looks like. Verify that all the wires pass continuity and are seated properly in the connector. They used hot glue to hold them in place, carefully work them free, don't yank them from the socket. The test button is directly connected to the power supply so that should work unless the switch or wiring is broken.

    Since that machine is poorly made, there are absolutely no interlocks. It will operate regardless of the lid being open or closed. Just because the beam isn't pointed in your direction doesn't mean it can't reflect off something. There are also some very, very high voltages in it. Use caution when you have your hands in it.

    Around the board:

    (EX+ EX-) (TL GND) -- these are connected to the two limit switches on the XY stage.
    The 2 four pin sockets are the XY stage stepper motors
    LO 5V GND 24V (power from the power supply)
    GND-YL-XL-GND-NC (this controls the power supply)

    Beyond that, I'm not sure what could cause the problems other than a faulty board. Unfortunately, I have not found very much support in various forums on the K40 machines. I have one (currently torn apart) -- was going to rebuild it with much better electronics but opted to purchase an Epilog in the near future.

  3. #3
    Join Date
    May 2017

    Re: new K40 chinese laser only fires if I press "test" button

    thanks.. i actually worked thru the night and the next morning a guy on facebook group offered to help me by sharing pics of his machine and voltages.. we found the lead wire going to the mainboard bad.. i pulled the mainboard and wire to power supply to test continuity and found the green wire showed no continuity.. upon further inspection after de-pinning the wire from the connector.. i found they had cut the cable when they crimped the connector.. i cut the wire off and cleaned it up.. soldered on a new wire (red) and then proceeded to check voltages again.. this time everything looked good.. installed the mainboard back and sent a file from corel and boom it worked..

    i will probably rewire the whole thing at a later date as i am going to be doing a few more mods but atleast it is working

    thanks for the offer to help.. i found numerous people who had the same problem but never got an answer.. so maybe if they search and see this.. they will have options..

  4. #4
    Join Date
    Nov 2019
    BlueLase I have the same issue. can you help me?

  5. #5
    Hi, I’m having this same issue with my K40, test laser working but laser but firing when I send in a file, but with the laser head still going through the motions as if it’s following the paths correctly for cutting and engraving.

    I’ve checked the wiring and no luck - anything look a bit odd/ questionable in my configuration attached?


Similar Threads

  1. Common Laser Problems and Solutions(1) - Y Axis movement issue on "Test"
    By Gweikelasers in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 3
    Last Post: 12-22-2016, 10:45 PM
  2. Another "Chinese laser not firing" post
    By LaserKobold in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 3
    Last Post: 11-03-2016, 06:51 PM
  3. laser tube fires only with test button!!
    By larry1988 in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 4
    Last Post: 08-20-2013, 10:30 AM
  4. Chinese laser: when I press the left button, head goes right...
    By Mchawkeye in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 7
    Last Post: 04-16-2012, 08:33 AM
  5. Laser fires on "Laser Test", but not from software
    By SimonArthur in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 6
    Last Post: 06-18-2008, 08:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts