545,577 active members*
7,091 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > HURCO > PC to Hurco kmb1 communication problem.
Results 1 to 10 of 10
  1. #1
    Registered
    Join Date
    Aug 2008
    Posts
    7

    Question PC to Hurco kmb1 communication problem.

    Just registered on cnczone, this is my first post so bare with me. I just purchased an old Hurco KMB1 w/BX, It has the upgraded BX-MPU board with both masters built in (G-code and conversational). I'm running MasterCam and have my communication line working. Been working on customizing a post to get a clean part program. I've pretty well got this ironed out, but here is the problem... As my G-Code transmits to the machine I'm getting a weird character at the end of each line of code. I've tried several things and I really don't think the post is generating this "end of line" character. I've went as far as simply manually typing and G0 at the PC and transmitting it to the machine, only to see G0 with the blasted(mystery character) tacked on then end... and to boot it will not load to the buffer. I suspect the problem is originating from my editor or my pc's comm port settings. If anyone has any advise or input on this issue, I would greatly appreciate it. Keep in mind, I've got a total of 2 days experience with this old hurco technology, but have been around more modern cnc's for many years. I'm hoping to tap in the some of the vast knowlege floating around out there, in hopes that someone has seen and conquored a problem like this.

    PS, just incase your wondering. I am able to manually type in blocks of info at the machine and run the program...No problem.

  2. #2
    Registered
    Join Date
    Jun 2008
    Posts
    1054
    Make sure your pc outputs the very first charater in the program as a % on a line of it's own and the very last character as an E on a line of it's own.

  3. #3
    Registered
    Join Date
    Aug 2008
    Posts
    7
    Bloke,
    Thanks for the input. Currently my post was not outputting the % and E. However, when I try to put a % sign in at the beginning, I get a parity error when I try to transmit.
    When I adjust the parity setting at the computer, I get a protocall violation. In short the only way I can get all the lines of code to transmit is omitting the %.

    What might help more than anything is knowing what my transmission settings should be.
    Currently this is what I have to work with. * indicates my current selections.

    Format: Ascii, EIA*, Bin
    Port: Com1, Com2*, Com3
    Baud rate is set at 9600
    Parity: Odd, Even, None*
    Data bits: 6, 7, 8*
    Stop bits: 1*, 2
    Hand shaking: None, Software*, Hardware
    EOL Delay: set at 0.0
    Strip carriage returns is turned on
    Strip Line feeds is turned on

  4. #4
    Registered
    Join Date
    Jun 2008
    Posts
    1054
    Try using 7 1 even instead of 8 1 none

  5. #5
    Registered
    Join Date
    Aug 2008
    Posts
    7
    Bloke,
    I tried the 7 1 even and it did not work.

  6. #6
    Gold Member
    Join Date
    Feb 2007
    Posts
    4557

    Smile

    Hi.

    First write a couple simple lines of Gcode in Notepad (Windows text editor) and try sending it.

    If it sends correctly then you know its not a communication problem.

    One step at a time using some logic would make it a little easier to diagnose.

    Welcome to the Zone.

    The following is the procedure for downloading code to the Mighty Hurco.

    To download " G " Code to Hurco you must have the buffer empty. To do this you must press "CHECK" then "ENTER," then "1" (program edit), then press "MASTER CLEAR". Once the buffer is empty press "3" (load program), then "3" (remote), then "NEXT BLOCK". The screen should read " Reading Leader ". You can now send your program to the Hurco machine. When the buffer fills, it will automatically DNC. Keep the computer link running and start the machine running, as it uses up the program lines it will ask the computer to send more. This will continue until it reaches an end of program command.



    Jeff....

  7. #7
    Gold Member
    Join Date
    Feb 2007
    Posts
    4557

    Smile

    This is a good read some of the information pertains to your Hurco, we are still looking for a KMB1 setup manual.

    http://www.hurco.com/AttachmentDatab...d.aspx?file=88

    Jeff...

  8. #8
    Gold Member
    Join Date
    Feb 2007
    Posts
    4557

    Smile

    Your Hurco must be in NC Mode.

    For NC Program Transfer Set Data Bits = 7, Parity = Even, Stop Bits = 1


    See attached document for more help.
    Attached Files Attached Files

  9. #9
    Registered
    Join Date
    Aug 2008
    Posts
    7
    Man what a relief, it is working now, I cut my first part a minute ago... the reading material and the advise went a long way. Bloke had told me 7, e, 1 and I tried it but it didn't work. I may need to get my stupid sign out, but the main problem was toggling it to ascii at mastercam comm setting. Initially their was long lines of text so I had to put the carriage returns and line feeds back in, but that was it. I can't say enough good about the zone community. It means a lot to me for folks to take the time out of their day to day to help a complete stranger. Thanks a bunch.

  10. #10

    Re: PC to Hurco kmb1 communication problem.

    hi, Im new here, I want to know how can I put the KMB1 in receiving mode, to receive the program by the rs-232 port communication?

Similar Threads

  1. hurco kmb1
    By adee1066 in forum HURCO
    Replies: 3
    Last Post: 06-26-2011, 07:47 AM
  2. chatter problem on Hurco Kmb1
    By J&RMachine in forum HURCO
    Replies: 7
    Last Post: 06-20-2008, 11:01 AM
  3. Hurco KMB1 dnc
    By mmachining in forum DNC Problems and Solutions
    Replies: 4
    Last Post: 01-25-2007, 05:06 AM
  4. Late 80's Hurco BMC 20 communication problem
    By tirebiter in forum DNC Problems and Solutions
    Replies: 1
    Last Post: 09-19-2006, 05:02 AM
  5. Hurco kmb1 help!!!
    By drill in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 1
    Last Post: 01-03-2006, 06:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •