532,052 active members*
3,176 visitors online*
Register for free
Login
Results 1 to 4 of 4
  1. #1

    Join Date
    Nov 2020
    Posts
    4

    Powace Cnc 6040Z 4 axis usb, not working

    Hi all I'm new here,
    I just assembled the machine in the title, I'm not sure about the limit switches wiring (3 pins from the switch, two pole from the cable, red and black), anyway I installed mach3 following the instructions from the seller and I plugged the machine on the computer with its usb cable but the machine doesn't move at all and mach3 sais that cnc is not connected, I took a photo of the control board maybe it helps.

  2. #2

    Join Date
    Nov 2020
    Posts
    4

    Re: Powace Cnc 6040Z 4 axis usb, not working

    Another thing is when I power on the VFD from the machine control box, the display blinks some numbers and the splindle doesn't rotate, speed potentiometer doesn't work (other buttons work), maybe it needs to be configured.

  3. #3

    Join Date
    Nov 2020
    Posts
    4
    Mach3 says : "No UsbMachBoard, Please plug it in!", cable is connected, i tried two and I get the same error

  4. #4

    Join Date
    Nov 2020
    Posts
    4

    Re: Powace Cnc 6040Z 4 axis usb, not working

    Today the seller sent me new plugin files for Mach3 and the machine started to work BUT there is a problem with Y axis, it moves bad and with difficult, even by hand when machine is powered off, I think it's a mechanical problem, when the machine is on is skipping steps and makes bad noises, I tried the sample g-code they sent me 3 times and the problem is easy to spot.

Similar Threads

  1. 6040Z Help with A axis
    By wiley125 in forum Chinese Machines
    Replies: 3
    Last Post: 04-27-2020, 03:04 AM
  2. CNC 6040Z X-Axis crawls, Help?
    By Pgold in forum General WoodWorking
    Replies: 0
    Last Post: 09-21-2018, 08:50 PM
  3. NEED HELP!!! spindle not working 6040z cnc
    By Asdfqaz1 in forum Chinese Machines
    Replies: 2
    Last Post: 08-31-2015, 12:39 AM
  4. 6040z 4-axis Router Help
    By ArkSeyonet in forum Chinese Machines
    Replies: 11
    Last Post: 04-20-2015, 02:22 PM
  5. 6040Z+S80 - using the 4th axis
    By MarcusWolschon in forum Chinese Machines
    Replies: 0
    Last Post: 08-13-2012, 12:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •