535,183 active members*
3,765 visitors online*
Register for free
Login
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    May 2017
    Posts
    81

    Read failed Auto disconnect

    Been having ongoing problem with stepper motors on x and y axis intermittently stalling and then restarting causing machine to loose position. At first thought it was bad connection on gecko drive plugs, changed plugs did not fix problem. Had energy dump circuits on each drive thought maybe that was problem removed them, their not needed, did not fix problem. Had a optical isolated on usb to kflop, removed that. Ran machine for 7 hours yesterday stepper motors did not stall but after 7 hours had a Read Failed error and Auto Disconnect, started machine over ran for another hour no problem. Started machine today ran a 10 minute warm up program then went to machine a part, half way through got the Read Fail error, restarted everything got the error a second time. Restarted everything again machine ran for over an hour with no problem. This Read Failed error makes the machine unreliable and loosing position makes the machine useless. Anyone know what causes the Read Failed error.

  2. #2
    Junior Member
    Join Date
    May 2006
    Posts
    3611

    Re: Read failed Auto disconnect

    Hi mirocha,

    "Read Failed - Auto Disconnect" occurs when the PC can't communicate to KFLOP. There are basically 2 causes for this. Either noise on the USB to the PC causes it to disconnect the connection. Or KFLOP resets/reboots for some reason. You can determine which is occurring by checking if KFLOP still has your configuration afterward or the default configuration. Or you might turn off one of KFLOP's LEDs. If the LED comes back on you know KFLOP rebooted. What Rev of KFLOP do you have? Rev 1.2 and before had some sensitivity to noise being picked up on the Reset inputs.
    TK
    http://dynomotion.com

  3. #3
    Registered
    Join Date
    May 2017
    Posts
    81
    Quote Originally Posted by TomKerekes View Post
    Hi mirocha,

    "Read Failed - Auto Disconnect" occurs when the PC can't communicate to KFLOP. There are basically 2 causes for this. Either noise on the USB to the PC causes it to disconnect the connection. Or KFLOP resets/reboots for some reason. You can determine which is occurring by checking if KFLOP still has your configuration afterward or the default configuration. Or you might turn off one of KFLOP's LEDs. If the LED comes back on you know KFLOP rebooted. What Rev of KFLOP do you have? Rev 1.2 and before had some sensitivity to noise being picked up on the Reset inputs.
    Never received the Read Failed error prior to removing the optical isolator on the usb started right after removing it, but seems I don’t have the stepper motor stalling issue with it remove doesn’t make sense to me, could they be related?

  4. #4
    Registered
    Join Date
    May 2017
    Posts
    81
    Quote Originally Posted by mirocha View Post
    Never received the Read Failed error prior to removing the optical isolator on the usb started right after removing it, but seems I don’t have the stepper motor stalling issue with it remove doesn’t make sense to me, could they be related?
    Rev 1.3

  5. #5
    Junior Member
    Join Date
    May 2006
    Posts
    3611

    Re: Read failed Auto disconnect

    Oops thought this was posted earlier

    Never received the Read Failed error prior to removing the optical isolator on the usb started right after removing it, but seems I don’t have the stepper motor stalling issue with it remove doesn’t make sense to me, could they be related?
    It sort of makes sense that removing the USB Isolator could add a GND path for noise to cause disconnects or resets. But a bit of a stretch how or why that would solve stepper stalls. Removing the isolation most likely adds a connection to Earth GND so maybe that somehow helps.

    You might try to determine if the stalls are a mechanical or electrical problem. If there is noise in the Step/Dir signals then there can be a loss or gain of any number of microsteps. But a mechanical stall will always result in some multiple of motor poles (4 full steps)
    TK
    http://dynomotion.com

Similar Threads

  1. Replies: 0
    Last Post: 06-24-2019, 02:40 AM
  2. Kmotion auto disconnect when sending signals via Step Response
    By spank in forum Dynomotion/Kflop/Kanalog
    Replies: 18
    Last Post: 03-19-2015, 12:25 AM
  3. KMotionDLL: Read Failed - Auto Disconnect
    By JeffS in forum Dynomotion/Kflop/Kanalog
    Replies: 13
    Last Post: 02-24-2015, 04:33 AM
  4. Machine Check: Failed.....Executive Load: Failed
    By NorthwestMike in forum Bridgeport / Hardinge Mills
    Replies: 1
    Last Post: 09-09-2014, 03:11 AM
  5. 465 x axis: read ID data failed
    By semmcco in forum Fanuc
    Replies: 6
    Last Post: 10-25-2012, 07:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •