547,434 active members*
2,298 visitors online*
Register for free
Login
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    Feb 2015
    Posts
    11

    "rescued" an old Gravograph LS500 XL

    Hello All,

    Either I did something stupid, or I did a good deal. Either way, what I did was buying an Gravograph LS500XL, which was stored (or dumped), in a moisty garage for about 6 years. The owner sold it to me including a ton of material to work with for about € 300. Not knowing if it would still run, I went for it anyway. I knew the chances are big it would no longer fire and the tube would need replacement or refilling. It's a Synrad metal tube, so it is high quality but chances are slim it survived that storing period.

    Anyway

    - At first startup it gave an end limit switch error which was quickly fixed (z-spring sensor was rusted and did no longer move).
    - Next I ran into a halt since it throws an "Defaut laser", machine is in french, but it means "Error (or fault) Laser".

    With the machine came 4 diskette drives with software and a link cable, but like one of those old pin cables which non of my computers still have. So I need to look for an old pc to link to this machine. Now the main question is, does this machine recognise a depleted tube, or are there different things causing this issue (power supply for example). Getting the tube refilled would cost met € 1200. But I have never worked with the machine before so it might be wasted money if it still not run after doing that.

    Any ideas on what I should do next to complete my "rescue" action on this machine?

    Thanks!

  2. #2
    Member
    Join Date
    Jul 2017
    Posts
    277

    Re: "rescued" an old Gravograph LS500 XL

    I just obtained a very old LS500XL

    As is for parts

    Did u get urs working?

    You can test voltages easy at power supply...48v and 30v...also pull out the board assembly and make sure all cables are connected.

  3. #3
    Member
    Join Date
    Jul 2017
    Posts
    277

    Re: "rescued" an old Gravograph LS500 XL

    Even with empty laser machine should still boot up to ready receive status

    Mine does...

  4. #4
    Registered
    Join Date
    Feb 2015
    Posts
    11

    Re: "rescued" an old Gravograph LS500 XL

    Quote Originally Posted by Shelby5041 View Post
    Even with empty laser machine should still boot up to ready receive status

    Mine does...
    I posted this a while ago, in the meantime I managed to make it work. There was indeed a cable not connected to the driver board. Once hooked up, everything worked. I've been running this machine almost daily and really grew a business out of this old machine :-)

    So all is good!

    Kr,

    Kenny

Similar Threads

  1. Multi-head or multiple extruder simotanious "follow me" copy print "mirror mode"
    By routermaker in forum General 3D Printer / 3D Scanner Discussion
    Replies: 1
    Last Post: 10-26-2019, 02:34 AM
  2. How can do ""manual stepper motor sizing for "rack and pinion"calculation""???
    By Medhat93 in forum Mechanical Calculations/Engineering Design
    Replies: 0
    Last Post: 03-03-2018, 01:50 AM
  3. Replies: 5
    Last Post: 01-12-2014, 07:07 PM
  4. X Axis "Goes Off Pattern", "Awry", "Skewed", "Travels"
    By DaDaDaddio in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 1
    Last Post: 05-06-2013, 09:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •